package-repositories

package-repositories

package-repositories – ¿Cómo soluciono el error de "búfer incomprensible" al ejecutar list-packages?

Pregunta: Cuando ejecuto list-packages en emacs en un Debian Buster actualizado (10.6), aparece el siguiente error: error in process sentinel: Error retrieving: https://stable.melpa.org/packages/archive-contents "incomprehensible buffer" La versión exacta del paquete emacs es 1: 26.1 + 1-3.2 + deb10u1. Cuando uso wget en esa URL y miro el archivo descargado, me parece una estructura de datos …

package-repositories – ¿Cómo soluciono el error de "búfer incomprensible" al ejecutar list-packages? Read More »

package-repositories – La conexión TLS a marmalade-repo.org:443 es insegura después de actualizar a Emacs 25

Pregunta: Cuando ejecuto Mx list-packages , aparece el siguiente error con Marmalade después de actualizar a Emacs 25. Certificate information Issued by: COMODO RSA Domain Validation Secure Server CA Issued to: Domain Control Validated Hostname: marmalade-repo.org Public key: RSA, signature: RSA-SHA256 Protocol: TLS1.2, key: ECDHE-RSA, cipher: AES-256-GCM, mac: AEAD Security level: Medium Valid: From 2015-07-12 …

package-repositories – La conexión TLS a marmalade-repo.org:443 es insegura después de actualizar a Emacs 25 Read More »

package-repositories – ¿ELPA está roto?

Pregunta: Emacs 26.1 empaquetado en Debian buster. Después de hacer Mx package-list-packages , puedo seleccionar cualquier paquete del repositorio de MELPA https://melpa.org/packages/ y luego instalarlo. Pero cuando intento obtener cualquier paquete del repositorio GNU ELPA https://elpa.gnu.org/packages/, aparece un error: Contacting host: elpa.gnu.org:443 package-install-from-archive: https://elpa.gnu.org/packages/ack-1.8.tar: Bad Request Y, por supuesto, obtengo el mismo error si intento …

package-repositories – ¿ELPA está roto? Read More »

package-repositories – ¿Cómo usar un tema instalado con melpa?

Pregunta: Quiero usar este tema: https://github.com/jonnay/emagicians-starter-kit/blob/master/themes/org-beautify-theme.org Lo instalé a través de list-package éxito. Intenté cargarlo a través de load-theme RET org-beautify RET pero dice Unable to find theme file for org-beautify . Así que agrego ~\.emacs.d\elpa\org-beautify-theme-20150106.956 a mi 'custom-theme-load-path y hago lo de load-theme nuevo, esta vez dice Undefined custom theme . ¿Cómo puedo activar …

package-repositories – ¿Cómo usar un tema instalado con melpa? Read More »

package-repositories – ¿Cómo puedo configurar un servidor ELPA?

Pregunta: Un amigo y yo queremos empezar a escribir paquetes emacs específicos para su uso en nuestra empresa. (Créame, nada de lo que escribamos será de mucho interés para nadie externo, es la integración con herramientas internas). Nos gustaría que la instalación y el mantenimiento de paquetes sean lo más fáciles posible y creemos que …

package-repositories – ¿Cómo puedo configurar un servidor ELPA? Read More »

package-repositories – gpg no encuentra la clave para el archivo elpa

Pregunta: Recibo este error al intentar descargar un paquete de ELPA: Failed to verify signature archive-contents.sig: No public key for 474F05837FBDEF9B created at 2018-11-28T14:10:03-0800 using DSA Command output: gpg: keyblock resource ‘/c/apps/emacs-25.3_1/bin/c:/users/myuserid/.emacs.d/elpa/gnupg/pubring.kbx’: No such file or directory gpg: Signature made Wed Nov 28 14:10:03 2018 PST gpg: using DSA key CA442C00F91774F17F59D9B0474F05837FBDEF9B gpg: Can’t check signature: …

package-repositories – gpg no encuentra la clave para el archivo elpa Read More »

package-repositories – ¿Cómo configurar un repositorio de paquetes privado?

Pregunta: He escrito varios paquetes para GNU Emacs, pero son inútiles fuera del entorno de mi empresa. Quiero poder compartir los paquetes con otros desarrolladores de mi empresa. También quiero que los paquetes sean fácilmente detectables a través de package-list-packages . Creo que el repositorio privado resolverá mis problemas, pero no puedo encontrar ningún manual …

package-repositories – ¿Cómo configurar un repositorio de paquetes privado? Read More »

package-repositories – Error al recuperar: https://elpa.gnu.org/packages/archive-contents (error http 400)

Pregunta: Estoy en esta versión de GNU Emacs en una computadora con Windows 10: GNU Emacs 26.3 (compilación 1, x86_64-w64-mingw32) de 2019-08-29 Durante las últimas semanas, Emacs informó este error al acceder a GNU Elpa cuando ejecuto "list-packages": Importando paquete-llavero.gpg … hecho error en el filtro de proceso: Error al recuperar: https://elpa.gnu.org/packages/archive-contents (error http 400) …

package-repositories – Error al recuperar: https://elpa.gnu.org/packages/archive-contents (error http 400) Read More »

package-repositories – La conexión TLS no se terminó correctamente

Pregunta: Cuando ejecuto package-list-packages , obtengo los siguientes errores: Failed to download `gnu’ archive. gnutls.c: [0] (Emacs) fatal error: The TLS connection was non-properly terminated. Estoy ejecutando Emacs 24.4 en Windows. Hasta esta semana, las descargas de paquetes se realizaban con normalidad. Probé esta guía sobre cómo configurar Emacs-GnuTLS-Windows. Intenté ejecutar este código desde la …

package-repositories – La conexión TLS no se terminó correctamente Read More »

Scroll to Top

istanbul avukat

-

web tasarım