package-repositories – ¿Cómo soluciono el error de "búfer incomprensible" al ejecutar list-packages?

Pregunta:

Cuando ejecuto list-packages en emacs en un Debian Buster actualizado (10.6), aparece el siguiente error:

error in process sentinel: Error retrieving: https://stable.melpa.org/packages/archive-contents "incomprehensible buffer"

La versión exacta del paquete emacs es 1: 26.1 + 1-3.2 + deb10u1. Cuando uso wget en esa URL y miro el archivo descargado, me parece una estructura de datos válida de e-lisp.

Esto ha funcionado en el pasado y funciona bien en la versión 27.1_5 del paquete emacs de MacPorts.

Respuesta:

Yo tuve el mismo problema. Resuelto agregando lo siguiente a init.el

    (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3")

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top

web tasarım