¿Cómo verifico la versión de NeoVim en vimscript?

Pregunta:

Puedo verificar la versión de vim usando v:version , y puedo verificar si estoy ejecutando en nvim haciendo has('nvim') . ¿Existe una variable como v:version en neovim para hacerme saber la versión de nvim, como 0.1.4 o 0.1.6 ?

Respuesta:

Como se mencionó en los comentarios en otra parte, puede usar has . Para genérico "es este neovim":

:echo has('nvim')

Para al menos la versión menor 0.1 (la más reciente a la fecha de este escrito):

:echo has('nvim-0.1')

Para al menos la versión de parche 0.1.6 :

:echo has('nvim-0.1.6')

Leave a Comment

Your email address will not be published.

Scroll to Top

istanbul avukat

-

web tasarım