openssl – error al cargar bibliotecas compartidas: libcrypto.so.1.1

Pregunta:

Cuando ejecuto "openssl", aparece un error como se muestra a continuación:

openssl: error al cargar bibliotecas compartidas: libcrypto.so.1.1: no se puede abrir el archivo de objeto compartido: no existe tal archivo o directorio "

Esto sucedió después de que intenté actualizar OpenSSL de acuerdo con este artículo.

¿Hay alguna forma de arreglar esto?

SO: CentOS 6.8 Servidor web: nginx / 1.10.2

Actualización n. ° 1:

[root@host ~]# yum info openssl
Installed Packages
Name        : openssl
Arch        : x86_64
Version     : 1.0.1e
Release     : 48.el6_8.3
Size        : 4.0 M
Repo        : installed
From repo   : system-updates
Summary     : A general purpose cryptography library with TLS implementation
URL         : ***
License     : OpenSSL
Description : The OpenSSL toolkit provides support for secure communications
            : between machines. OpenSSL includes a certificate management tool and
            : shared libraries which provide various cryptographic algorithms and
            : protocols.

Available Packages
Name        : openssl
Arch        : i686
Version     : 1.0.1e
Release     : 48.el6_8.3
Size        : 1.5 M
Repo        : system-updates
Summary     : A general purpose cryptography library with TLS implementation
URL         : ***
License     : OpenSSL
Description : The OpenSSL toolkit provides support for secure communications
            : between machines. OpenSSL includes a certificate management tool and
            : shared libraries which provide various cryptographic algorithms and
            : protocols.

Respuesta:

Tenía el mismo problema después de instalar la última versión de openssl 1.1.0c, resolví el problema copiando los archivos de la biblioteca libcrypto.so.1.1 , libcrypto.a y libssl.so de /usr/local/lib64 a la biblioteca compartida en /usr/lib64 .
Después de copiar las bibliotecas, debe crear el enlace simbólico.

ln -s libcrypto.so.1.1 libcrypto.so
ln -s libssl.so.1.1 libssl.so

Después de crear el enlace simbólico, también se requirió la reconstrucción de la caché ldconfig :

sudo ldconfig

Leave a Comment

Your email address will not be published.

Scroll to Top

istanbul avukat

-

web tasarım