linux – Error de Samba 4.9.0 ./configure lmdb

Pregunta:

Soy muy nuevo en Linux, estoy instalando Samba y estoy tratando de convertir mi Centos 7 en un ADDC.
Sin embargo, siempre que quiero configurar, aparece el siguiente mensaje:

Comprobando lmdb> = 0.9.16 mediante comprobación de encabezado: no encontrado
Samba AD DC y –enable-selftest requieren lmdb 0.9.16 o posterior

Cuando se usa yum install lmdb, dice que ya está instalado.

[root @ localhost samba-4.9.0] # yum install lmdb
Complementos cargados: rapidmirror Velocidades de espejo de carga desde el archivo host en caché * base: mirrors.standaloneinstaller.com * epel: mirrors.powernet.com.ru * extras: ftp.rezopole.net * actualizaciones: distrib-coffee.ipsl.jussieu.fr Paquete lmdb -0.9.22-2.el7.x86_64 ya instalado y última versión
Nada que hacer

Respuesta:

La dependencia real para instalar ( para Red Hat Enterprise Linux 7 / CentOS 7 / Scientific Linux 7 ) es lmdb-devel .

En lugar de seguir un tutorial aleatorio para una versión de Samba ahora EOL, es mejor que siga la guía oficial (y actualizada) de Samba: compilar Samba desde el código fuente , dependencias de paquetes requeridas para compilar Samba , configurar Samba como un directorio activo Controlador de dominio

Sin duda, el tutorial al que se vinculó NO enumera las dependencias actuales de Samba para CentOS 7.

Deja un comentario

Tu dirección de correo electrónico no será publicada.

Ir arriba