debugging – ¿Hay alguna configuración en Emacs para elegir perlbrew sobre perl?

Pregunta:

Tengo un proyecto de Perl (desarrollado en Ubuntu 14.04) que no se puede construir en perl 5.18.2 , pero funciona en Perlbrew 5.22.0 . He intentado usar Mx perldb en Emacs pero parece que Emacs llama a Perl 5.18.2 por defecto. ¿Hay alguna forma de elegir Perlbrew en Emacs para depurar?

Respuesta:

Puede personalizar el comando ejecutado por perldb cambiando gud-perldb-command-name . Su valor predeterminado se establece en "perl -d" .

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top

web tasarım