apache-2.4 – Instale apache 2.4 en debian wheezy

Pregunta:

Tengo un debian y cuando intento instalar apache2.4 con

apt-get update
apt-get install apache2

Tengo la versión 2.2, ¿alguien sabe cómo instalar la 2.4?

Respuesta:

Si realmente necesita apache 2.4, recomendaría usar jessie para la distribución de su máquina en lugar de wheezy si es posible para evitar tener un entorno de fuentes mixtas que lo colocaría en una configuración menos utilizada y menos compatible.

De lo contrario, si hay una razón específica que lo haga querer usar 2.4, tal vez haya una solución para actualizar sus archivos php u otra para que funcione en Apache 2.2 y permanecer en wheezy.

Pero si realmente desea ingresar a un entorno de fuentes mixtas, es posible usar apt pinning, que implicará 2 pasos:

  • Agregar fuentes de jessie a su /etc/apt/sources.list
  • Agregar una preferencia de fijación en / etc / apt /ferences

Aquí hay más información al respecto: https://wiki.debian.org/AptPreferences

Tenga en cuenta que es posible que se enfrente a nuevos problemas de dependencia de apt a medida que las actualizaciones de su máquina evolucionen e instale módulos de apache con dependencias mixtas a 2.2 o 2.4. Si es una complicación aceptable para sus necesidades, puede seguir adelante.

Leave a Comment

Your email address will not be published.

Scroll to Top

istanbul avukat

-

web tasarım