Problema de migración: el marcado de Drupal no se representa en las páginas de CiviCRM

Pregunta:

Moví un sitio de Drupal 6 / CiviCRM 4.3 a un servidor de desarrollo, y estoy obteniendo un comportamiento realmente extraño. Cuando visito una página de Drupal en el sitio copiado, todo se muestra como se esperaba. Sin embargo, cuando visito una página de CiviCRM, la parte de CMS del marcado no se encuentra en la fuente. Es casi como si cada página de CiviCRM se entregara como un fragmento.

Para ser más específico, cuando voy a / civicrm y veo la fuente, obtengo un marcado que comienza con:

<div id="crm-container" class="crm-container" lang="en" xml:lang="en">

<div id="menu-container" style="display:none;">
  <ul id="civicrm-menu">
  ...

Las etiquetas HTML de apertura y cierre y todo el HTML contenido en el tema de Drupal están completamente ausentes. Lo mismo parece ser cierto para todas las páginas de CiviCRM.

He intentado lo siguiente:

  • revisar mi archivo de configuración de CiviCRM
  • revisar mi directorio y la configuración de recursos
  • borrar cachés de Drupal
  • vaciando sitios / default / civicrm / templates_c
  • eliminar sitios / default / civicrm / ConfigAndLog / Config.IDS.ini
  • ejecutando drush civicrm-update-cfg
  • comprobar los registros de errores de Apache, Drupal y CiviCRM
  • echando sal sobre mi hombro izquierdo

¿Alguna idea de qué podría causar un comportamiento tan extraño? ¿Sugerencias para algo que podría haber perdido en mi migración o un buen lugar para poner el código de depuración para llegar al fondo de esto?

Respuesta:

Ah, creo que he visto esto antes, ¿se metió por casualidad con su archivo de configuración de CiviCRM?

Vuelva a verificar su configuración de CIVICRM_UF , Civi podría estar tropezando si cree que el CMS es algo diferente de lo que realmente es.

Para Drupal 6 quieres CIVICRM_UF = 'Drupal6'

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top

web tasarım