drupal 8 – ¿Qué versiones de los componentes de Symfony se utilizan desde el núcleo?

Pregunta:

¿Qué versión de Symfony usa Drupal para los componentes de Symfony? ¿Es un objetivo admitir las últimas versiones de los componentes o simplemente no es posible?

Respuesta:

Es más exacto decir que Drupal 8 usa componentes de Symfony, en lugar de todo Symfony. Si observa 'core / composer.json' verá todos los componentes individuales que usa Drupal enumerados. Las versiones precisas que se instalan se enumeran en el archivo 'composer.lock'.

Drupal 8.2.x usa las versiones 2.8 de estos componentes.

Para Drupal 8.3.x, hay problemas abiertos para actualizar a 3.1 y 3.2 , pero aún están en proceso. (Creo que puede haber un problema con 3.3, pero no puedo encontrarlo).

El objetivo es comenzar a rastrear las versiones 3.x, pero la conversión no ha sido sencilla.

Leave a Comment

Your email address will not be published.

Scroll to Top

istanbul avukat

-

web tasarım