apt – Wine 1.7 no se instala en Xubuntu 15.10

Pregunta:

Entonces, después de configurar mi instalación de Xubuntu ayer, intenté instalar Wine 1.7 usando ppa: ubuntu-wine / ppa. Sin embargo, después de hacer sudo apt-get install wine1.7 , me sigue dando este error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.44-0ubuntu1) but it is not going to be installed
           Depends: wine1.7-i386 (= 1:1.7.44-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

Probé varias soluciones que encontré en línea, como quitar automáticamente, agregar la arquitectura i386, limpiar mis paquetes y arreglar mis instalaciones de apt-get. Sin embargo, después de probar todas las soluciones que pude encontrar, wine1.7 todavía no se instala. No estoy seguro de si esto es culpa de mi computadora o del ppa, pero si otros pudieran compartir sus hallazgos, sería genial.

Gracias, Elly

Según lo solicitado, aquí está el resultado de la apt-cache policy wine1.7 wine1.7-amd64 wine1.7-i386 :

wine1.7:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main amd64 Packages
wine1.7-amd64:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main amd64 Packages
wine1.7-i386:i386:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main i386 Packages  

y la salida para sudo apt-get install wine1.7-amd64 wine1.7-i386 :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7-amd64 : Depends: libgphoto2-port10 (>= 2.5.2) but it is not installable
                 Recommends: libgnutls26 but it is not installable
                 Recommends: wine-gecko2.34 but it is not installable
                 Recommends: wine-mono4.5.4 but it is not installable
 wine1.7-i386:i386 : Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not installable
                     Recommends: libgnutls26:i386 but it is not installable
                     Recommends: libpcap0.8:i386 but it is not going to be installed
                     Recommends: wine-gecko2.34:i386 but it is not installable
                     Recommends: wine-mono4.5.4:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

Respuesta:

La dependencia en la que falla es libgphoto2-port10 , que no es Wily. Puede intentar instalar manualmente los archivos DEB de Trusty:

http://packages.ubuntu.com/trusty/libgphoto2-port10

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top

web tasarım