javascript – WordPress 5.5 – ReferenceError: commonL10n no es un error definido

Pregunta:

Acabo de actualizar a la última versión de wordpress 5.5 y mi tema dejó de funcionar. Las categorías ya no se seleccionan automáticamente cuando hago clic en el botón.

https://prnt.sc/u030gj

Respuesta:

Este es el boleto de Trac 51223 :

commonL10n y otros JS globales eliminados sin compatibilidad con versiones anteriores

En WordPress 5.5, las traducciones localizadas bajo commonL10n fueron reemplazadas por wp.i18n .__ sin aviso de obsolescencia o compatibilidad con versiones anteriores. Los complementos que usan commonL10n ahora tienen errores de JavaScript introducidos al actualizar WordPress que pueden romper la funcionalidad del sitio.

Se corrigió en 5.5.1 agregando una capa de compatibilidad. La mejor solución es actualizar a 5.5.1.

commonL10n todavía está en desuso, sin embargo, y se eliminará en 5.7 .

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top

web tasarım